Technical Specifications

  • Pure Java. Flux is written in pure Java. As a result, the same Flux code runs on any platform that has a supported version of Java. Flux runs equally well on IBM mainframes, PCs, and Macs.
  • Supported Java Versions. Flux 7.11 requires Java 6 to run. Flux 7.11 supports Java 6, 7, and 8 from Oracle. Numerous customers have found Flux works with Java versions from other vendors, and Flux provides validation and support for these versions through its consulting services.
  • Supported Databases. Note: The JDBC Database Drivers being used must match the release of the database being used. Using database drivers that pre-date the database version is not supported. As an example, using JDBC Drivers for SQL Server 2000 is not supported when using SQL Server 2008.
    • Oracle 8 and more recent versions.
    • IBM DB2 8.1 and more recent versions.
    • SQL Server 2005 and more recent versions with row versioning enabled using the Microsoft JDBC drivers
    • PostgreSQL 8.1 and more recent versions.
    • MySQL 5.0 and more recent versions using the com.mysql.jdbc.Driver JDBC driver with InnoDB tables
    • Apache Derby (Built into Flux. Does not cluster.)
    • H2 (In-memory database built into Flux. Data is lost on restart. Does not cluster.)
  • Supported Application Servers. Using an application server is optional.
    • WebLogic Server 10.3, 9.2, 9.1, 8.1, 7.0, and 6.1
    • WebSphere 6.1, 6.0, 5.1, 5.0, and 4.0
    • JBoss 7.0
    • Tomcat 6.0, 5.5, and 5.0
    • Jetty 6 and 5
  • Supported Web Browsers. Using the Web-based Operations Console is optional. It supports the following web browsers. NOTE:Internet Explorer is known to perform significantly slower than other browsers. We recommend using one of the other supported browsers listed where possible.
    • Firefox
    • Internet Explorer 8, 7 and more recent with compatibility mode set
    • Google Chrome
    • Safari
  • Supported LDAP Servers.Using LDAP for security authentication is optional.
    • Microsoft Active Directory
    • Apache Directory Server
  • Supported Operating Systems. Flux works on any operating system that supports Oracle's JVM, version 6, 7, or 8. Specifically, Flux is known to work on 64-bit and 32-bit Windows, Linux, Mac OS X, Solaris, HP-UX, AIX, AS/400, and OpenVMS systems.
  • Minimum Memory Requirements. Flux Engine: 512 MB RAM. Flux Agent: 512 MB RAM. Flux Operations Console: 512 MB RAM. A cluster of Flux engines and their agents is managed from a single Operations Console instance.
  • Minimum CPU requirements. Flux requires an equivalent CPU of a 1.0-1.2 GHz 2007 Opteron or 2007 Xeon processor (or equivalent to a 2006 1.7 GHz Xeon processor). NOTE: Memory and CPU requirements may increase as the usage of Flux increases. As the usage, size, and complexity of your Flux flow charts increase, CPU and memory usage may scale accordingly.
  • Minimum Screen Resolution. The Flux Operations Console requires a minimum screen resolution of 1280 x 1024.
  • Virtualized Environments. Flux can run in any virtualized environment (including VMWare and VirtualBox) where a stable JVM is available.
  • Active-Active Clustering. Engines automatically cluster when pointed to the same database. Flux supports clusters of up to 35 engines. NOTE: If using a cluster of more than 4 engines, the cluster networking engine configuration option should be disabled for best performance.

Flux Maintenance Policy

The following versions of Flux continue to be supported and will be supported indefinitely: Flux 7.x, 6.5, 5.3, and 3.1.

Java Technology Support Information

Flux depends on Java technology. From time to time, new versions of Java technology appear and older versions are retired. Because Flux runs in a Java environment, we encourage you to take proactive measures to ensure that Flux is not running in an obsolete software environment. However, we recognize and accommodate the above listed application servers that use older versions of Java.